Welcome to unstablemolecules.com, the discussion home for mightyavengers.net, uncanon.com and uncannyxmen.net!

UXN/MAN sites running slow - FIXED!

That's right, News as in latest updates posted on uncannyxmen.net!
Post Reply
User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

UXN/MAN sites running slow - FIXED!

Post by Dean Clayton » 12 Oct 2020, 11:56

Jsut a heads up, while the forum is working fine, we are having a few issues with the site and it running very slow.
not sure why but i'll be investigating over the next few days to see what is going on, please be patient :lol:
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

User avatar
Spectral Knight
Posts: 1925
Joined: 14 Apr 2007, 21:00

Re: UXN/MAN sites running slow - investigating

Post by Spectral Knight » 12 Oct 2020, 12:30

This morning I was getting different error codes - 504 on the site, but 502 on the forum - very odd.

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - investigating

Post by Dean Clayton » 12 Oct 2020, 19:12

those are related to some of the ways the web server caches the site, and at the time i was trying a few different tests to see if it worked.

I've currently turned off caching that we had, so now you are more likely to ge ta "service unavailable" message if it doesn't load. however if you refresh browser it should be fine after about 5 minutes
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

User avatar
Lavettye
Posts: 1218
Joined: 22 Feb 2016, 18:33
Location: Germany

Re: UXN/MAN sites running slow - investigating

Post by Lavettye » 12 Oct 2020, 19:44

Yes, it was definitely unrelated to the visitor pool problem you mentioned a while back, as I tried logging on with three different IPs from two different browsers, and still couldn't access either site or forum.

The other times the site was seemingly unavailable over the past few months, changing your IP address did help though. As Dean explained to me (techno-babble for dummies), the server puts site visitors into pools, and occasionally a pool may overstretch its ressources by there being too many paralell requests, so the server temporarily locks the pool out. With a different IP address, you get shuffled into another pool.
[PL_2.0]

User avatar
Aeon
Posts: 1087
Joined: 30 Apr 2019, 12:05

Re: UXN/MAN sites running slow - investigating

Post by Aeon » 12 Oct 2020, 22:21

And in short and easy for...

Image

User avatar
Nu-D
Posts: 2842
Joined: 18 Dec 2013, 00:22
Location: Durham, NC
Contact:

Re: UXN/MAN sites running slow - investigating

Post by Nu-D » 13 Oct 2020, 00:20

I’m getting a bad gateway/server stopped responding message. Neither site will load at all. The forum seems a little pokey too.
He/him/his

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - investigating

Post by Dean Clayton » 14 Oct 2020, 16:42

forum seems a little better compared with the main site but still investigating i'm afraid .. turning it off and on again doesn't work as well as I hoped
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - investigating

Post by Dean Clayton » 14 Oct 2020, 19:17

I'm not going to jinx myself but, feedback appreciated on site access please
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

User avatar
Aeon
Posts: 1087
Joined: 30 Apr 2019, 12:05

Re: UXN/MAN sites running slow - investigating

Post by Aeon » 14 Oct 2020, 19:45

had 2 or 3 hickups in the last 30 mins

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - investigating

Post by Dean Clayton » 14 Oct 2020, 20:13

what do you mean by hickups? pages take long to load? pages not loading? also let me know what page and i'll take a look.

I've spotted that images on the site are being used on other sites through hotlinking. we used to block this, but i forgot to re-enable this properly when we launched mightyavengers.net and i need to look into fixing this again. its not a huge deal at the moment, but if they are pulling images that don't exist that can impact the site if its a huge number of requests a minute.
fyi - it got really bad where tens of Gigs of site bandwidth was being used by the fandom wiki sites and a few independant sites hot linking the files instead of just uploading them to their own server (I'll skip over whwther its right to take the images and pass them off as your own , as its not like we draw them). That was back around 2008-2010. some hosting companies charge you for the bandwidth a site uses, so you can imagine how that can freak some people out. Luckily we don't have that issue as I've always avoided that type of hosting.
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

User avatar
Aeon
Posts: 1087
Joined: 30 Apr 2019, 12:05

Re: UXN/MAN sites running slow - investigating

Post by Aeon » 14 Oct 2020, 20:23

I think it was one time-out message and two page is not available messages. Both from the forum page.
But just short „hickups“. The page loaded right afterwards normally again.

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - investigating

Post by Dean Clayton » 15 Oct 2020, 08:34

ahh ok, cool.

i'm keen to see how things are with the sites over the next week, so please if peopel can give some general views ( its good , its bad, i get timeouts, pages don't load, pages too slow)
but if anything isn't working let me know what page you are trying to access :)
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

elixir86
Posts: 487
Joined: 08 Apr 2007, 15:55
Location: Italy
Contact:

Re: UXN/MAN sites running slow - investigating

Post by elixir86 » 15 Oct 2020, 09:27

Dean Clayton wrote:
15 Oct 2020, 08:34
ahh ok, cool.

i'm keen to see how things are with the sites over the next week, so please if peopel can give some general views ( its good , its bad, i get timeouts, pages don't load, pages too slow)
but if anything isn't working let me know what page you are trying to access :)
The site works flawlessly for me.

User avatar
Lavettye
Posts: 1218
Joined: 22 Feb 2016, 18:33
Location: Germany

Re: UXN/MAN sites running slow - investigating

Post by Lavettye » 15 Oct 2020, 13:32

I had two Time-Outs at the forum yesterday, which I could solve with an IP address change. Didn't bother to check the site at the same time, but usually whenever it's this Time-out message, both are affected for me.
[PL_2.0]

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - investigating

Post by Dean Clayton » 15 Oct 2020, 17:54

@elixir86 - good to hear :)
@Lavettye, with the changes i've made we shouldn't have th site impact the forum and vice versa.
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

Cosmos666
Posts: 246
Joined: 13 Aug 2017, 01:59

Re: UXN/MAN sites running slow - FIXED!

Post by Cosmos666 » 16 Oct 2020, 00:04

The Mighty Avengers link on the top of the main page is redirecting me back to UXM.net.

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - FIXED!

Post by Dean Clayton » 16 Oct 2020, 08:39

Cosmos666 wrote:
16 Oct 2020, 00:04
The Mighty Avengers link on the top of the main page is redirecting me back to UXM.net.
good spot! have fixed
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

Cosmos666
Posts: 246
Joined: 13 Aug 2017, 01:59

Re: UXN/MAN sites running slow - FIXED!

Post by Cosmos666 » 16 Oct 2020, 13:37

Dean Clayton wrote:
16 Oct 2020, 08:39
Cosmos666 wrote:
16 Oct 2020, 00:04
The Mighty Avengers link on the top of the main page is redirecting me back to UXM.net.
good spot! have fixed
Thanks! ;)

User avatar
Lavettye
Posts: 1218
Joined: 22 Feb 2016, 18:33
Location: Germany

Re: UXN/MAN sites running slow - FIXED!

Post by Lavettye » 17 Oct 2020, 08:30

Well, I was browsing the forum this morning, had opened a thread and read it, then wanted to open another one and got the network time-out message again. Changed to a diferent IP and here I am.
[PL_2.0]

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - FIXED!

Post by Dean Clayton » 17 Oct 2020, 09:23

@Lavettye, ok thats definitely a different issue to the performance one. could you send me a screenshot of the network error ( with the url you were trying to access), what time it happens and also what your 2 ip addresses are (the one it stops working on and the one it then works with)
I can then use that to trace thru the server logs to see what might be happening
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

User avatar
Lavettye
Posts: 1218
Joined: 22 Feb 2016, 18:33
Location: Germany

Re: UXN/MAN sites running slow - FIXED!

Post by Lavettye » 17 Oct 2020, 10:14

The screenshot error was in German, not sure if that will help you. But it said "Netzwerkfehler: Zeitüberschreitung" IIRC.
It was 10:25 my time, so 9:25 yours.

And I have more than two IPs at my disposal. The second one (with which I got in) is the one that I made the above post from. I'll send it to you in a PM.
[PL_2.0]

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - FIXED!

Post by Dean Clayton » 18 Oct 2020, 13:08

thanks :)
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

User avatar
Aeon
Posts: 1087
Joined: 30 Apr 2019, 12:05

Re: UXN/MAN sites running slow - FIXED!

Post by Aeon » 20 Oct 2020, 18:01

Not sure if it is related, but today I received two email notifications for the current Warp Draft, which never happened before.

I usually subscribe to a draft game in which I participate for the „bell“ notifications, but I never received emails before.

User avatar
Dean Clayton
Posts: 5080
Joined: 18 Jan 2007, 22:42

Re: UXN/MAN sites running slow - FIXED!

Post by Dean Clayton » Yesterday, 18:19

Aeon wrote:
20 Oct 2020, 18:01
Not sure if it is related, but today I received two email notifications for the current Warp Draft, which never happened before.

I usually subscribe to a draft game in which I participate for the „bell“ notifications, but I never received emails before.
it maybe that wit hthe latest change i've made, email notifications from the server are no longer treated as spam... for me in gmail, it still goes to spam, even though i tell gmail they aren't.
Why not contribute to one of our sites? The pay is non existent, but vacation allowance is fantastic!

Post Reply